click fraud detection

Получение ссылки на общий модуль

Дата публикации: 13.04.2017

Рассмотрим задачу, когда имя общего модуля точно не известно или может измениться, а используемое имя процедуры этого общего модуля известно и постоянно.

 

 

 

 

 

 

Рассмотрим на примере:

Процедура НашаПроцедура()

ИспользуемыйМодуль = ОбщийМодуль("НужноеИмяМодуля");

Если ИспользуемыйМодуль <> Неопределено Тогда

                                Результат = ИспользуемыйМодуль.НужнаяПроцедураОбщегоМодуля();

                КонецЕсли;

КонецПроцедуры

Функция ОбщийМодуль(Имя)              

                Если Метаданные.ОбщиеМодули.Найти(Имя) <> Неопределено Тогда

Модуль = Вычислить(Имя); // ВычислитьВБезопасномРежиме не требуется, т.к. проверка надежная.

                Иначе

                               Модуль = Неопределено;

                КонецЕсли;

                               Возврат Модуль;          

КонецФункции

 

Автор: Дина Королева.

 

Аренда разработчика 1С

Опытные специалисты, 1 400 руб./час

Подробнее

Другие записи в блоге

22.10.2018
Рассмотрим задачу, когда колонку СКД нужно выводить в зависимости от выполнения какого-то условия.Рассмотрим на примере внешнего отчета (без формы отчета, только СКД), условие вывода колонки задано в...
22.10.2018
Рассмотрим задачу, когда отчет на СКД нужно расшифровать другим отчетом. Рассмотрим на примере конфигурации УТ 11.4.1.271.Для этого нужно добавить строки кода в процедуру ОбработкаРасшифровки общего...
22.10.2018
Рассмотрим задачу, когда нужно обновить типовую конфигурацию, в которую внесены изменения. Рассмотрим на примере конфигурации ЗУП, в которой в документ НачислениеЗарплаты был добавлен новый реквизит...

Подпишитесь на блог

Все интересные статьи нашего блога на Вашем почтовом ящике!

Подписка
 

Сервис звонка с сайта RedConnect