Заказать звонок

Получение ссылки на общий модуль

13.04.2017

Рассмотрим задачу, когда имя общего модуля точно не известно или может измениться, а используемое имя процедуры этого общего модуля известно и постоянно.

 

 

 

 

 

 

Рассмотрим на примере:

Процедура НашаПроцедура()

ИспользуемыйМодуль = ОбщийМодуль("НужноеИмяМодуля");

Если ИспользуемыйМодуль <> Неопределено Тогда

                                Результат = ИспользуемыйМодуль.НужнаяПроцедураОбщегоМодуля();

                КонецЕсли;

КонецПроцедуры

Функция ОбщийМодуль(Имя)              

                Если Метаданные.ОбщиеМодули.Найти(Имя) <> Неопределено Тогда

Модуль = Вычислить(Имя); // ВычислитьВБезопасномРежиме не требуется, т.к. проверка надежная.

                Иначе

                               Модуль = Неопределено;

                КонецЕсли;

                               Возврат Модуль;          

КонецФункции

 

Автор: Дина Королева.


Возврат к списку

Наши услуги и вакансии

Разработчики
на full-time
Программист 1С на 8 часов в день
от 1 600 руб/час
Позадачная
разработка 1С
Доработки и развитие любых решений на платформе 1С
Стоимость по оценке
Карьера в Neti

Вакансии разработчиков и консультантов 1С
З.П. от 100 000 рублей