Заказать звонок

Запуск обработки в регламентном задании

09.07.2019
Рассмотрим задачу запуска обработки в регламентном задании. В модуле обработки должна быть прописана экспортная процедура ВыполнитьЗадание() Экспорт, пример кода процедуры (Код – или код элемента в справочнике внешних обработок, или полное имя обработки, например, «Обработка.ЗапускИзРегламентногоЗадания»): Процедура ВнешняяОбработка(Код = Неопределено, БезопасныйРежим = Истина) Экспорт МетаданныеОбъекта = Метаданные.НайтиПоПолномуИмени(Код); Если МетаданныеОбъекта <> Неопределено Тогда Если Метаданные.Обработки.Содержит(МетаданныеОбъекта) Тогда Обработка = Обработки[МетаданныеОбъекта.Имя].Создать(); Обработка.ВыполнитьЗадание(); КонецЕсли; Возврат; КонецЕсли; СсылкаНаВнешнююОбработку = Справочники.ВнешниеОбработки.НайтиПоКоду(Код); ДвоичныеДанные = СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить(); Если ДвоичныеДанные <> Неопределено Тогда Попытка ИмяФайла = ПолучитьИмяВременногоФайла("epf"); ДвоичныеДанные.Записать(ИмяФайла); Если СсылкаНаВнешнююОбработку.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка ИЛИ СсылкаНаВнешнююОбработку.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.ПечатнаяФорма Тогда ВнОбработка = ВнешниеОбработки.Создать(ИмяФайла, БезопасныйРежим); Иначе ВнОбработка = ВнешниеОтчеты.Создать(ИмяФайла, БезопасныйРежим); КонецЕсли; ВнОбработка.ВыполнитьЗадание(); Исключение ЗаписьЖурналаРегистрации("Регламентное задание. Внешняя обработка: ОШИБКА!", УровеньЖурналаРегистрации.Предупреждение); КонецПопытки; КонецЕсли; КонецПроцедуры

Возврат к списку

Наши услуги и вакансии

Разработчики
на full-time
Программист 1С на 8 часов в день
от 1 600 руб/час
Позадачная
разработка 1С
Доработки и развитие любых решений на платформе 1С
Стоимость по оценке
Карьера в Neti

Вакансии разработчиков и консультантов 1С
З.П. от 100 000 рублей